FIXED First Aid Belt not finding bandage while equipped.

Dan

Staff Member
Administrator
Game Master
Moderator
Thanks are you using the built in client maco for self bandaging?
 

Xtal

Neophyte III
Community Supporter
I was using the UOSteam macro, but just tried the built in and and it can't find it either.
 

Dan

Staff Member
Administrator
Game Master
Moderator
So the UOSteam macro is probably core coded so SOL there. As new features get added someone with either need to make a macro that checks it or more people will need to move over to RazorEnhanced, which is actively being developed.
http://www.razorenhanced.org

Now the in-game option on the client side is an issue we may be able to fix. It just needs another option to check for the first aid belt. @Dexter
 

DaBeanCounter

Apprentice III
Community Supporter
For UOSteam, try writing a script.


if not @findobject 'firstaidbelt'
headmsg 'Target your first aid belt'
promptalias 'firstaidbelt'
endif
if @findtype 0xe21 'any' 'firstaidbelt'
useobject 'found'
waitfortarget 2000
target! 'self'
endif
 

Xtal

Neophyte III
Community Supporter
Yeah there are work arounds, I'm not worried about it, just obviously wasn't working as intended. So Razor is good now huh? Weird...
 

Dan

Staff Member
Administrator
Game Master
Moderator
Razor enhanced not normal Razor. I provided you a link above.
 

DewCono

Apprentice
Community Supporter
I'll use UOSteam till it stops connecting to UO! EnhancedRazor wasn't my cup of tea :(
 

Dan

Staff Member
Administrator
Game Master
Moderator
The belt should work with the built in macros on the actual UO client, that's the bug that will get fixed.
 

Dan

Staff Member
Administrator
Game Master
Moderator
Hey could someone with the Bandage belt let me know if the client macros now pick it up?
 

DewCono

Apprentice
Community Supporter
After the client update (which claims to fix the first aid belt in the CC):

With the First Aid Belt equipped (and the bag itself closed with bandages in it) it says: "You must have a stack of bandages..."
With the First Aid Belt unequipped (and the bag itself closed with bandages in it) it says: "You must have a stack of bandages..."
With the First Aid Belt unequipped (and the bag itself opened with bandages in it) it says: "You must have a stack of bandages..."

With the First Aid Belt equipped (and the bag itself opened with bandages in it) it works.

The belt ONLY works while equipped, and with the bag opened on your screen (the second you close it, it cannot remember where the bandages were and says "You must have a stack of bandages...")
 

Dan

Staff Member
Administrator
Game Master
Moderator
@Dexter I confirmed on UO that it should work, regardless.

Maybe we need a custom script, sort of like EquipLastWeapon to make it work? It should be able to pull from the belt without the belt being "open" but as DewCono pointed out it does not.
 

Dan

Staff Member
Administrator
Game Master
Moderator
We are also aware that the belt is missing some properties.
FirstAidBelt.png

A fix is incoming.
 

Dexter

Staff Member
Lead Developer
Game Master
Moderator
Well, unless the client finds the bandages, it doesn't send the packet to teh server so this is 100% a client issue, at least for now. Dan said there is a fix on TC, so we'll have to wait and see. Missing properties are in the ServUO repo.
 

DewCono

Apprentice
Community Supporter
Ah I thought those fixes went live when Dan updated the shard this afternoon (which he asked for someone to test it in chat) so I made this post for him.
 

Dan

Staff Member
Administrator
Game Master
Moderator
So before, even open, it did not find them. Now it does. The issue is should it find them closed? That we do not know yet.

On the Publish 103 TC notes it said a fix was on TC. This currently leads us to believe that maybe it will require some code however until it goes LIVE we will not know for sure.
 

Dan

Staff Member
Administrator
Game Master
Moderator
So as long as the container is open it will find them

The missing properties were also added.

This issue has been fixed (as best we can).

@Xtal has been awarded 5 Sovereigns.
 

Dan

Staff Member
Administrator
Game Master
Moderator
We are aware of an issue where they lost the 2 HP Regen. This will be fixed after the next scheduled restart.
 
Top