FIXED Boats, Galleons and the lighthouse oh my.

RedBeard

Apprentice II
Revered Member
Community Supporter
1. When I asked a dock master to dry dock my galleon he said he couldn't find it meanwhile it was parked within 5 tiles of him.

2.My Galleon seemed to leave a image of itself behind once moved it.
1555769889362.png

3. Found a decaying boat really close to the Floating Emporium blocking me from getting to it, while all ships should have a timer in this area and be moved away after timer expires. While attempting to move said boat I could leave my galleon to board it but couldn't re-board my galleon from that dragon boat, it even says you can't. This doesn't sound right.
4. I attempted to launch a dragon ship while having a galleon already deployed from the shoreline and said I already have a boat, which is wrong, you should be able to launch multiple vessels, maybe not more then one galleon but if you get into boats and fishing at all, you would know this would kill the idea of wanting one of these period(galleon).
5. I placed a lighthouse and It doesn't give a context menu or any confirmation that it does what it should. When you interact with it it should tell you the coords of ship it should let you know that a ship is linked to it etc... I don't know if this lighthouse works period... It should sync with galleon and even have its appearance change to reflect the condition of the ship. (I tried place LH then Galleon and Galleon then LH still no confirmation or context menu)
6. I find the galleons will stop for no reason and having to maneuver around invisible objects or possible tiles at the wrong 'z' who knows.

At this moment I chose to dry dock my galleon until some issues are resolved.
I've read at uo.com some new features with regards to the Rising Tide and Forgotten Treasures coming, sounds interesting, but I'm hoping we can solve these issues before introducing those updates.
 
Last edited:

Dan

Staff Member
Administrator
Game Master
Moderator
Yeah Dexter plans on working on current code and not anything from those publishes yet.

1. Thanks we will take a look at it.

2. This is a client side bug when unloading big multis. Usually running 2x off screen, recalling to another facet, or re-logging fixes it. Happens from time to time on real UO.

3. So after 20 minutes boats should be moved out. However the rest of it needs a little better explaining. How can I replicate it?

4. http://www.uoguide.com/Ultima_Online:_High_Seas / Since High Seas in 2010 you have been restricted to ONE boat (regardless of type) and one row boat per character. This is largly due to the trade missions and the minister finding your ship hold.

5. So the lighthouse can store up to 7 boats. One for each character. It should be synced to whatever character is currently on's boat. Could you please place a resource link in regards to everything else you are saying it should be doing?

6. Where are you sailing? I have never noticed this but really only tested in Trammel.
 

RedBeard

Apprentice II
Revered Member
Community Supporter
Yeah Dexter plans on working on current code and not anything from those publishes yet.

1. Thanks we will take a look at it.

2. This is a client side bug when unloading big multis. Usually running 2x off screen, recalling to another facet, or re-logging fixes it. Happens from time to time on real UO.

3. So after 20 minutes boats should be moved out. However the rest of it needs a little better explaining. How can I replicate it?
4. http://www.uoguide.com/Ultima_Online:_High_Seas / Since High Seas in 2010 you have been restricted to ONE boat (regardless of type) and one row boat per character. This is largly due to the trade missions and the minister finding your ship hold.

5. So the lighthouse can store up to 7 boats. One for each character. It should be synced to whatever character is currently on's boat. Could you please place a resource link in regards to everything else you are saying it should be doing?

6. Where are you sailing? I have never noticed this but really only tested in Trammel.
2. All my accounts see it and the re-log jump facet didn't work, oh well...
3. https://uo.com/wiki/ultima-online-wiki/gameplay/npc-commercial-transactions/the-floating-emporium-sea-market/
This states that after 20 min. it moves the abandoned vessels to the marker buoys a short distance from the structure. I haven't seen Buoys.
4. I understand why you can't run more then one ship now, it is unfortunate to be tied to one though...sigh.
5. https://forum.uo.com/discussion/3767/lighthouse-linking-very-important
Ok I found a post on what I was doing wrong as far as linking to it, but there isn't much more info available about a context menu like I mentioned above, perhaps I'm mistaken. I also see the Harbor Master will reissue a rune so you can recall to a lost galleon for some reason I thought the LH told you where to find it.
6. I was sailing east of Skara Brae in Trammel and east of Shame, there were 3 locations on that side of the map I will include coordinates once I cross them again, it seems to have been one tile I had to go around each time.
 

Dan

Staff Member
Administrator
Game Master
Moderator
Next time grab few a few [where spots to go look at.
 

Dexter

Staff Member
Lead Developer
Game Master
Moderator
#3, thte boats have to be in the region. I've found a small boat on Heritage, right outside the region.
 

Dexter

Staff Member
Lead Developer
Game Master
Moderator
#6, we're going to need an exact location when this happens, probably in a separate thread.
 

Dexter

Staff Member
Lead Developer
Game Master
Moderator
#1, which dock master, and where exactly was your boat? I may need to re-work the way it looks for your boat. On EA, it has to be near by. On ServUO, it goes by region, so we may have to do a simple range check.
 

RedBeard

Apprentice II
Revered Member
Community Supporter
#1, which dock master, and where exactly was your boat? I may need to re-work the way it looks for your boat. On EA, it has to be near by. On ServUO, it goes by region, so we may have to do a simple range check.
The Sea Market I tried to park boat in a slip then tried to pull up right next to him neither worked.
 

Dexter

Staff Member
Lead Developer
Game Master
Moderator
ya im adding a 100 tile range.It may have been right outside the region.
 

Dexter

Staff Member
Lead Developer
Game Master
Moderator
So tell me if im wrong, #1 is the only bug. I understand #6 will need to be addressed on a case by case basis and most likely require its own bug submittal.
 

Dan

Staff Member
Administrator
Game Master
Moderator
We need to confirm lighthouses are correctly registering the boats for the account.
 

Dan

Staff Member
Administrator
Game Master
Moderator
Maybe a "HasBoat" flag in the PM since you can only have 1 boat at a time?
 

Dexter

Staff Member
Lead Developer
Game Master
Moderator
BaseBoat has one. I added GetBoat to find your boat as well.
 

Dexter

Staff Member
Lead Developer
Game Master
Moderator
Verified. It tells you when you place/drydock your boat.
 

Dan

Staff Member
Administrator
Game Master
Moderator
Okay I believe all the issues have been fixed.

Redbeard can you just verify if the lighthouse is working or not?
 

RedBeard

Apprentice II
Revered Member
Community Supporter
Okay I believe all the issues have been fixed.

Redbeard can you just verify if the lighthouse is working or not?
It appears to work as far as linking the boat. I cant verify if it places decayed boats in moving crate though
This accnt only has 2 characters on it so i cant verify the total allowable boats per accnt either at this time.
 

Dan

Staff Member
Administrator
Game Master
Moderator
Thanks but each characters boat showed up, when on the respected character?
 

Dexter

Staff Member
Lead Developer
Game Master
Moderator
its 1 per character. It follows its own rules. The lighthouse is account bound, so any player on that account will have it linked.
 

Dan

Staff Member
Administrator
Game Master
Moderator
Alright then all these issues have now been fixed.

@RedBeard has been awarded 40 Sovereigns.
 
Top